Scenarios
On the login screen a warning message is shown stating "Your computer's time appears to be set incorrectly and you may have problems logging in." as shown below:
Alternatively, a user enters their login credentials and presses the Submit button, the page then appears to log in the user (either to the admin or members area) and then redirects them back to the login page.
Cause
This is typically caused by the users computer system clock being incorrect.
Upon login the system generates an authentication token, this token is based on the users computer time and the server time, when the server tries to match both if they do not match then the token is invalidated, meaning that the user is effectively logged out, leading to them being redirected back to the login page.
Checks
Go to www.timeanddate.com and verify that the computer time matches that shown for your location on the website.
Ask the user to try a different device to verify if the problem is account related or device related. If they are able to log in on a different device this typically suggests a problem with the original device time settings.
Solution
Follow the guide for your operating system below, guides have been created for Windows 10 and macOS Monterey, however most versions of Windows and macOS are similar so the steps should be relevant.
Windows 10 & 11
- Go to the Start Menu and type Settings
- Select Time and language
- Make sure Windows 10/11 is allowed to set the date and time settings automatically by following the next steps
- Depending on the options you see, the "Set the time automatically" may be on or off
- Shown below it is set to "Off"
- Turn this on by clicking on the toggle icon once.
- It should now look like below
- Ensure that the time zone is correct for your location by repeating the steps above but for the "Set the time zone automatically" option below the "Set the time automatically".
- You may find that if the settings are checked then unchecking and checking again will force the time to synchronise
- You can also force the time to be updated by pressing the "Sync now" button, as shown below
MacOS (pre 15.x)
- From the Apple menu, select System Preferences
- Click Date & Time
- Click the Lock icon and unlock with your password
- Select the Set date and time automatically checkbox, it may already be ticked, unticking and ticking again should force it to synchronise.
MacOS (15.x and above)
From the Apple menu select System Settings
- Click Date & Time from within the General section
- Select the Set date and time automatically checkbox, it may already be ticked, unticking and ticking again should force it to synchronise.
iOS
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Go to Settings
> General > Date & Time.
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Turn on the following:
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Set Automatically: iPhone gets the correct time over the network and updates it for the time zone you’re in. Some networks don’t support network time, so in some countries or regions, iPhone may not be able to automatically determine the local time.
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